[HowTo/Cómo] Instalación de Catalyst 8.6 en Ubuntu Hardy

19 06 2008

Bueno, en realidad también es válido (en teoría) para cualquier versión de Ubuntu/Mint (y no sé si Debian en general) y cualquier versión de los Catalyst.

Como indico en la noticia anterior, esta nueva release de los Catalyt trae una importante mejora y es 100% aconsejable instalarla.

Nota: los que poseen una ATI Radeon 9250 o inferior deben usar los drivers libres ya que dejaron de estar soportadas por AMD/ATI hace tiempo y, además, funcionan mejor.

La instalación de estos drivers es muy sencilla, sólo tendremos que seguir los siguiente pasos:

DESCARGAMOS EL DRIVER

Desde la página oficial de AMD/ATI: Enlace.

INSTALAMOS PAQUETES NECESARIOS

$ sudo aptitude update

$ sudo aptitude install build-essential module-assistant fakeroot dh-make debhelper debconf
libstdc++5 dkms linux-headers-$(uname -r)

BORRAMOS LOS DRIVERS ANTIGUOS

Abrimos Synaptic (Sistema>Administración>Synaptic), buscamos “fglrx” y marcamos para desinstalar todo lo relaccionado con fglrx (xorg-driver-fglrx fglrx-kernel-source y fglrx-amdcccle).

Luego en un terminal:

$ sudo rm /usr/src/fglrx-kernel*.deb

PREPARAMOS LO PAQUETES .DEB PARA NUESTRA DISTRIBUCIÓN

Abrimos una terminal y vamos hacia donde hayamos descargado el driver. (Ej: si está en el escritorio tendríamos que escribir “cd Escritorio” o “cd Desktop“, si estuviera en nuestra carpeta personal no habría que hacer eso.) Y luego:

$ sudo sh ati-driver-installer-8-6-x86.x86_64.run --buildpkg Ubuntu/hardy

NOTA: el guión que viene antes de “buildpkg” son, en realidad, 2 guiones. Si tenemos Ubuntu Hardy o Mint Elysa lo dejamos como he puesto, si tenemos otras versiones de Ubuntu cambiaz hardy por gutsy, feisy, edgy o dapper según vuestra versión.

CONFIGURAMOS ALGUNAS COSAS

Tenemos que editar un par de archivos ara que no se produzcan errores.

Primero:

$ sudo gedit /etc/default/linux-restricted-modules-common

y en la línea:

DISABLED_MODULES="

Ponemos:

DISABLED_MODULES="fglrx"

Segundo: (esto no me fue necesario, pero por si acaso…)

$ sudo gedit /etc/modprobe.d/blacklist-restricted

y en la línea (si estuviera, si no está no hay que hacer nada):

“blacklist fglrx”

Ponemos:

#“blacklist fglrx”

INSTALAMOS LOS PAQUETES QUE CREAMOS ANTES

$ sudo dpkg -i xorg-driver-fglrx_8.501*.deb fglrx-kernel-source_8.501-0*.deb fglrx-amdcccle_8.501-0*.deb

Cambiando, si fuera necesario, 8.501-0 por vuestra versión. Tendrán que instalarse sin dar ningún error.

CONFIGURAMOS EL DRIVER

$ sudo aticonfig --initial --input=/etc/X11/xorg.conf
$ sudo aticonfig --overlay-type=Xv

Nos aseguramos de que se haya configurado correctamente el xorg.conf:

$ sudo gedit /etc/X11/xorg.conf

Y buscamos la sección parecida a esto:

Section “Device”
Identifier     “aticonfig-Device[0]-0”
Driver         “fglrx”
Option        “VideoOverlay” “on”
Option        “OpenGLOverlay” “off”
EndSection

La parte del Driver y Option tiene que quedar igual.

Reiniciamos el ordenador. No vale reiniciar las X.

Una vez reiniciado, abrimos una terminal y escribimos esto para ver si está correctamente instalado:

$ fglrxinfo

Debería dar una salida parecida a esta:

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI RADEON 9600 Series
OpenGL version string: 2.1.7659 Release

Si todo ha salido bien, deberíamos poder correr sin problemas Compiz Fusion y jugar a cualquier juego.

Espero que os haya servido.

Anuncios

Acciones

Information

14 responses

20 06 2008
Lorenz0x

Gracias x el aporte

20 06 2008
Driver ATI 8.6 liberado « Un Bioinformatiquillo

[…] instalarlos [CacahueTux] No Comments Leave a Commenttrackback addressThere was an error with your comment, please try […]

24 06 2008
Marcos

Se agradece, llevo días buscando una guía decente, demás esta decir que esta me ayudo un montón

28 06 2008
j3r3

Excelente tutorial!

28 06 2008
Gryphus

Tengo un pequeño problema. Tras seguir el tutorial paso a paso, e iniciar sesion, me sale una pantalla blanca. (Si, la endemoniada pantalla blanca), asi que tengo que volver a la configuracion inicial del xorg.

Si utilizo envy, todo va correctamente, pero en cambio siempre me “salta” un pantallazo negro (que ni siquiera me permite acceder al terminal, solo puedo resetear) en cuanto se utiliza cualquier cosa que requiera aceleracion grafica (flxgears por ejemplo)

28 06 2008
Malpy

¿Qué modelo tienes? ¿qué te sale al hacer “fglrxinfo” en consola?

Así de primeras no se me ocurre nada.

4 07 2008
Pablo

Hola, acabo de realizar el tutorial y todo está perfecto menos el parpadeo de las ventanas de vídeo o que requieren renderización como juegos 3D etc.

He oído que es normal cuando tienes ati y compiz, pero, a estas alturas ¿no hay una solución sin tener que desactivar compiz?

Gracias.


Mi equipo:
Ubuntu Hardy 8.04
Núcleo Linux 2.6.24-19-generic
ATI Sapphire HD3450
AMD Athlon 3200+

6 07 2008
Diego

tengo problemas al momento de crear los paquetes .deb
Lo que me tira es esto:
dpkg-shlibdeps: warning: symbol XauFileName used by debian/xorg-driver-fglrx/usr/sbin/atieventsd found in none of the libraries.
dpkg-shlibdeps: warning: debian/xorg-driver-fglrx/usr/sbin/atieventsd shouldn't be linked with libXrender.so.1 (it uses none of its symbols).
dpkg-shlibdeps: failure: couldn't find library libfglrx_gamma.so.1 needed by debian/xorg-driver-fglrx/usr/bin/fglrx_xgamma (its RPATH is '').
Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
dh_shlibdeps: command returned error code 512
make: *** [binary] Error 1
dpkg-buildpackage: failure: debian/rules binary gave error exit status 2
Removing temporary directory: fglrx-install.ZZ9374

Soy novato en esto asi que espero que me puedan ayudar.

6 07 2008
Malpy

@Pablo – Eso sigue pasando con las aplicaciones que no se usan en pantalla completa, es decir, como Google Earth o Zattoo. Sin embargo, las aplicaciones que requieren 3D a pantalla completa ya no parpadean.

@Diego – Mira en Synaptic (Sistema>Aplicaciones>Synaptic) a ver si tienes instalado “libxrender1” y “libxrender-dev”. Adegurate de haber instalado las dependencias que digo al principio.

En un rato actualizo el tutorial que he visto que tiene algún error.

9 09 2008
Inukaze

Hola, muy buenas, mira, como debo instalar en el Hardy Ubuntu 8.04, la ATI Radeon 9250 PowerColor Series ???? es de 256 MB

Tengo muchos problemas al intentar instalarlo, y la ultima version oficial que la soporto los drivers 8.28 , no los puedo compilar el “make.sh” me devuelve un error de “unspect token in line 37 (” o algo asi por el estilo y no lo puedo compilar manualmente , y como no tengo idea de programacion no le meto mano al codigo xD hehe

Me gustaria mucho saber, que debo instalar, para usar la version de los controladores libres, “rv280” que es lo que supuestamente es, segun lo que he encontrado , ese deberia ser el driver para mi tarjeta.

Sabes como puedo configurar la version gratis del controlador, y porcierto sabes si tiene soporte de 2D y 3D ???

9 09 2008
Malpy

Pues no tienes que instalar nada. Ubuntu trae la última versión de los controladores libres para tu tarjeta (que son los que debes usar). Tienen soporte 2D y 3D y dan buen resultado (de hecho, la Radeon 9250 es la que mejor resultado da con esos controladores).

Los 8.28 (propietarios) son los últimos que dieron soporte a tu tarjeta por parte de ATI y, además de ser antiguos, dan muy mal resultados y no puedes usar AIGLX.

Para comprobar que tienes aceleración 3D funcionando abre una terminal (APLICACIONES>ACCESORIOS>TERMINAL) y escribe “glxinfo” (sin comillas). Entre las primeras líneas que saldrán hay una que pone “Direct Rendering: yes”. Si pone ese “yes” es que tienes aceleración funcionando.

26 03 2009
.: Dragon Unico :.

Buenas,

Tengo grandes dudas (de hecho solo es una pero grande)… ya se ha solucionado el problema con las tarjetas de terminacion 50? (X1950 es la que me interesa…)

Saludos y gracias… en caso de estar solucionada, creo que le dare un respiro y desinstalare el virus del PC.

15 02 2010
Inukaze

Bueno con la antigua , ATI Radeon 9250 PowerColor Series de 256MB AGP 4X ,
Cuando instale los drivers “fglrx” del repositorio y tenia de driver “radeon” en el Xorg.conf

al ejecutar glxinfo
“Direct Rendering: no”

Luego con los drivers propietarios , fglrx .
al ejecutar glxinfo
“Direct Rendering: yes”

Pero a la final , como el OpenGL con el driver libre , no existia , y con el oficial si , a la final cambie la tarjeta de video de las despreciables ATI , por una de mis queridas NVIDIA ^^ , una NVIDIA GeForce 5700LE de 256MB

Apenas inicio Ubuntu , me salio para instalarle los drivers ( version 173.14.25 ) ^^ . Le hize clic a “Activar” solo espere 3 mins de instalacion y luego reinicie , y listo , tengo Aceleracion 2D & 3D

19 05 2014
socialgo.com

Don’t look for it on prepaid carriers; they just recently got the Galaxy S2, and it costs more than you probably want to pay up-front if you’re going
prepaid. The latest ad scan features eight pages of deals overall,
which also include the Sony Play – Station 3 and Xbox 360 video game systems, as well as other
electronics gadgets and accessories. For starters,
instead of having a small aluminum unibody chassis, it’s
this big honking plastic thing, with a 5-inch, 1080p touchscreen that’s so
sensitive you can use it with gloves on (or even gesture in the air above it).

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




A %d blogueros les gusta esto: