[Cómo] Mantener limpio nuestro sistema (Ubuntu/Debian)

15 05 2008

Muchas veces instalamos un programa con Apt/aptitude/Synaptic y después de probarlo no nos gusta y lo desinstalamos. Esto no supondría ningún “problema” si no fuera porque la mayoría de esos programas tienen dependencias que se instalan junto al mismo y, sin embargo, no se desinstalan cuando lo desinstalamos.

Este hecho no afecta al rendimiento del sistema por lo que (por lo general) no molestan, pero puede que tengamos un disdo duro de poca capacidad o simplemente queremos tener el sistema libre de librerías inútiles.

Deborphan es una herramienta que busca librerías huérfanas y las elimina del disco duro, una utilidad bastante útil (valga la redundancia).

Lo instalamos así:

Lee el resto de esta entrada »





Tutoriales actualizados

15 05 2008

Debido a Ubuntu Hardy he actualizado algunos tutoriales para que tengan compatibilidad con él. También he complementado el de Sopcast.





Voipbuster y Voipstunt con Ekiga: llamadas gratis a fijos

11 05 2008

Ayer por la tarde llovía y me dio por buscar la manera de usar VoIP o telefonía ip en GNU/Linux. Me puse a buscar las empresas más fiables y me encontré con Voipbuster y Voipstunt (que si no me equivoco sus creadores son los mismos).

Ambos servicios te permiten llamar gratuitamente a una gran cantidad de paises de forma gratuita (aunque sólo a fijos). En teoría las estas llamadas gratuitas tienen un límite de duración, pero yo he llamado hasta 35 minutos seguidos (y porque colgué yo).

Después de trastear un rato encontré la forma de hacerlos funcionar con Ekiga. (lectura recomendada)

Lee el resto de esta entrada »





100 aplicaciones imprescindibles para Ubuntu

10 05 2008

Acabo de encontrarme con una pedazo de recopilación de aplicaciones interesantes para Ubuntu (y GNU/Linux en general). Viene de la mano de Alejandrox y además de citar los programas, los ha categorizado y puesto una pequeña descripción además de un tutorial de cómo instalarlos en Ubuntu y su página oficial.

Os recomiendo a todos su lectura ya que seguro que más de una aplicación os interesa.

Enlace: Mis 100 aplicaciones imprescindibles para ubuntu





Solución a error de Frostwire en Ubuntu Hardy

10 05 2008

Si habéis intentado ejecutar Frostwire en Ubuntu Hardy (aunque creo que también pasa en otras versiones) os habréis dado cuenta de que no ejecuta…:(

Si lo intentamos ejecutar desde una terminal, el resultado es algo como esto:

Starting FrostWire…
Java exec found in PATH. Verifying…
Suitable java version found [java = 1.6.0]
Configuring environment…
Loading FrostWire:
java.lang.UnsatisfiedLinkError: Can’t load library: /usr/lib/jvm/java-6-openjdk/jre/lib/i386/motif21/libmawt.so
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1666)
at java.lang.Runtime.load0(Runtime.java:787)
at java.lang.System.load(System.java:1022)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1767)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1684)
at java.lang.Runtime.loadLibrary0(Runtime.java:840)
at java.lang.System.loadLibrary(System.java:1047)
at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:67)
at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:47)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.loadLibraries(Toolkit.java:1610)
at java.awt.Toolkit.(Toolkit.java:1632)
at com.limegroup.gnutella.gui.Main.showInitialSplash(Main.java:67)
at com.limegroup.gnutella.gui.Main.main(Main.java:39)

******************************************************************
Something went wrong with FrostWire.
Maybe you’re using the wrong version of Java?
(FrostWire is tested against and works best with with Sun’s JRE, Java 1.4+)
The version of Java in your PATH is:
java version “1.6.0″
OpenJDK Runtime Environment (build 1.6.0-b09)
OpenJDK Client VM (build 1.6.0-b09, mixed mode, sharing)

Esto es debido a que “el java” que se instala en Ubuntu con los “ubuntu-restricted-extras” es OpenJDK. Para soluciona el error hay que instalar el java de Sun, así:

$ sudo aptitude install sun-java6-jre

Y una vez instalado correr este comando:

$ sudo update-java-alternatives -s java-6-sun

Y ahora probamos a correr Frostwire. Debería funcionar.





Instalar Network Manager correctamente en Arch Linux

5 05 2008

Como ya comenté el otro día, tras mi pequeña historia con Ubuntu 8.04 instalé Arch Linux para ver qué tal va. La verdad es que su desempeño es muy bueno, pero ya comentaré eso otro día.

Una de las cosas que tuve que hacer después de instalar el entorno gráfico fue instalar Network Manager ya que tengo wifi y me gusta conectarme a todas las wifis “libres” de contraseña. Pensé que sería tan fácil como hacer esto:

$ pacman -S gnome-network-manager

o si estamos en KDE:

$ pacman -S knetworkmanager

y para xfce:

$ pacman -S gnome-network-manager xfce4-xfapplet-plugin

Pero no terminaba de funcionar bien ya que se reiniciaba solo y además no configuraba correctamente la red.

Tras buscar un rato encontré la solución:

Lee el resto de esta entrada »





Apagar los altavoces del portátil al conectar los auriculares (o altavoces externos)

3 05 2008

Otro de los problemas que tuve con Ubuntu Hardy Heron (y creo que esto pasa en casi todos los Ubuntu) es que cuando conectaba los auriculares, los altavoces no se apagaban y (obviamente) era molesto.

El portátil es un Fujitsu Siemens Amilo y tiene una placa de sonido Intel HD audio Controller.

Tras investigar un rato logré solucionarlo:

Lee el resto de esta entrada »