Apagar los altavoces del portátil al conectar los auriculares (o altavoces externos)

3 05 2008

Otro de los problemas que tuve con Ubuntu Hardy Heron (y creo que esto pasa en casi todos los Ubuntu) es que cuando conectaba los auriculares, los altavoces no se apagaban y (obviamente) era molesto.

El portátil es un Fujitsu Siemens Amilo y tiene una placa de sonido Intel HD audio Controller.

Tras investigar un rato logré solucionarlo:

Lo que hice fue recompilar alsa para que detectara mi configuración de hardware. Fue tan fácil como hacer esto:

$ sudo aptitude install module-assistant

Una vez instalado:

$ cd /usr/src

$ sudo module-assistant update

$ sudo module-assistant prepare

$ sudo module-assistant auto-install alsa

$ sudo shutdown -r now

Y una vez que reincie debería haberse solucionado el problema o por lo menos a mí me funcionó.

En la wiki de Ubuntu dan más posibles soluciones y la lista de portátiles afectados. Si la que os he puesto yo no os funciona probad con las otras. También tened en cuenta que las solcuiones que dan son principal mente para Ubutnu Gutsy aunque yo tengo Hardy y me ha funcionado.

Enlace: Wiki Ubuntu

Actualizado: parece ser que cuando se actualiza alsa se vuelve a desconfigurar, con lo que hay que volver a realizar el proceso.

Anuncios

Acciones

Information

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




A %d blogueros les gusta esto: